PHP is amongst the most commonly used programming languages. It is exceptionally popular as it’s free software, which can be used to develop interactive sites like social networking websites, Internet shops or online teaching portals instead of static HTML-based websites. A PHP module should be available on the server where a PHP site is hosted so that its PHP code can be read. As there are no license taxes for this type of module and the language itself provides countless possibilities for the web-based apps that you set up, there are 100s of millions of PHP-driven websites. Additionally, there are a vast number of open-source PHP scripts, which you can use for your websites without having to possess any programming knowledge. As there’re a few versions of PHP, you ought to verify that the very same version that you used whilst developing your site is installed on the web server too.

PHP 4, PHP 5 and PHP 7 Support in Cloud Web Hosting

We’ve made the decision not to prevent our current and future customers from picking what PHP version their websites will use, which means that if you order a cloud web hosting package from us, you will be able to select between versions 4, 5 and 7, not only for the web hosting account itself, but also for each individual domain name that you host. This can be done with only one single mouse click from our in-house developed Hepsia Control Panel via which all shared accounts are administered, so you will not need any technical or programming expertise. You will be able to host websites built with both new and old PHP scripts without any problem, so if you’d like to leave your present web hosting services provider and move over to us, you can rest assured that all the websites that you have created throughout the years will continue to run perfectly.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers

If you have a site built with an older PHP version and you’ve dedicated time and efforts to setting it up, plugging security breaches and adding content, you will need to find a web hosting service that can support it, since most hosting companies these days support only the most recently released PHP version and abandon the previous ones. We, on the other hand, have decided to permit you to choose the version that your very own sites require. Our semi-dedicated hosting service support PHP 4, PHP 5 and PHP 7, which means that you’ll be able to run both older and newer scripts without forfeiting any manual settings or misspending time trying to make your sites compatible with the web hosting environment. The version can be changed via the Hepsia Control Panel and such a change will affect the entire semi-dedicated account, but you’ll also have the ability to choose a different version of PHP for each individual site that you host in your account using an .htaccess config file.